PT-2025-6510

CVE-2024-11895

·

Published

2025-02-17

·

Updated

2025-02-21

Description by

CVSS 3.1
6.4
Medium
MetricsAV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions Online Payments – Get Paid with PayPal, Square & Stripe plugin for WordPress versions prior to 3.20.0
Description The issue is related to Stored Cross-Site Scripting via the plugin's shortcodes due to insufficient input sanitization and output escaping on user-supplied attributes. This allows authenticated attackers with contributor-level access and above to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Recommendations For versions prior to 3.20.0, update to a version newer than 3.20.0 to resolve the issue. As a temporary workaround, consider restricting access to the plugin's shortcodes to minimize the risk of exploitation. Avoid using user-supplied attributes in the shortcodes until the issue is resolved.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾