PT-2025-6520
CVE-2024-12386
·
Published
2025-02-11
·
Updated
2025-02-20
Description by
CVSS 3.1
8.1
HighMetricsAV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:H
Name of the Vulnerable Software and Affected Versions
WP Abstracts plugin for WordPress versions up to, and including, 2.7.3
Description
The issue is due to missing nonce validation on multiple functions, making it possible for unauthenticated attackers to delete arbitrary accounts via a forged request. This can happen if an attacker can trick a site administrator into performing an action such as clicking on a link.
Recommendations
For WP Abstracts plugin for WordPress versions up to, and including, 2.7.3, update to a version higher than 2.7.3 to resolve the issue.
As a temporary workaround, consider restricting access to sensitive functions that rely on nonce validation until a patch is available.
Found an issue in the description? Have something to add? Feel free to write us 👾