PT-2025-6573
CVE-2024-13578
·
Published
2025-02-17
·
Updated
2025-03-17
Description by
CVSS 3.1
6.4
MediumMetricsAV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
WP-BibTeX plugin for WordPress versions up to, and including, 3.0.1
Description
The issue is related to Stored Cross-Site Scripting via the plugin's 'WpBibTeX' shortcode due to insufficient input sanitization and output escaping on user-supplied attributes. This allows authenticated attackers with contributor-level access and above to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Recommendations
For WP-BibTeX plugin for WordPress versions up to, and including, 3.0.1, update to a version later than 3.0.1 to resolve the issue.
As a temporary workaround, consider disabling the 'WpBibTeX' shortcode until a patch is available.
Restrict access to pages that use the 'WpBibTeX' shortcode to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾