PT-2025-7047
CVE-2025-24928
·
Published
2025-01-28
·
Updated
2026-10-19
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:N
Name of the Vulnerable Software and Affected Versions
libxml2 versions 2.12.10 and earlier, 2.13.x versions prior to 2.13.6
Description
The issue is a stack-based buffer overflow in the
xmlSnprintfElements function in valid.c. To exploit this, DTD validation must occur for an untrusted document or untrusted DTD.Recommendations
For libxml2 versions 2.12.10 and earlier, and 2.13.x versions prior to 2.13.6, update to version 2.12.10 or 2.13.6 or later to resolve the issue.
As a temporary workaround, consider disabling DTD validation for untrusted documents or DTDs until a patch is available.
Found an issue in the description? Have something to add? Feel free to write us 👾