PT-2025-7231
CVE-2025-26770
·
Published
2025-02-14
·
Updated
2025-02-17
Description by
CVSS 3.1
6.5
MediumMetricsAV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L
Name of the Vulnerable Software and Affected Versions:
Waymark versions n/a through 1.5.0
Description:
The issue is related to improper neutralization of input during web page generation, which allows for stored Cross-site Scripting (XSS). This enables attackers to inject malicious scripts into the application, potentially leading to unauthorized actions on behalf of the user.
Recommendations:
For versions n/a through 1.5.0, update to a version later than 1.5.0 to resolve the issue. As a temporary workaround, consider restricting user input to minimize the risk of exploitation. Avoid using potentially vulnerable API endpoints until the issue is resolved. At the moment, there is no information about additional mitigation measures.
Found an issue in the description? Have something to add? Feel free to write us 👾