PT-2025-7356

CVE-2024-13476

·

Published

2025-02-19

·

Updated

2025-03-06

Description by

CVSS 3.1
7.5
High
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Name of the Vulnerable Software and Affected Versions LTL Freight Quotes – GlobalTranz Edition plugin for WordPress versions up to, and including, 2.3.11
Description The issue is related to SQL Injection via the 'engtz wd save dropship' AJAX endpoint due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Recommendations For versions up to, and including, 2.3.11, update to a version later than 2.3.11 to resolve the issue. As a temporary workaround, consider restricting access to the 'engtz wd save dropship' AJAX endpoint until a patch is available. Avoid using the vulnerable parameter in the affected AJAX endpoint until the issue is resolved.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾