PT-2025-7368

CVE-2024-13564

·

Published

2025-02-21

·

Updated

2025-03-18

Description by

CVSS 3.1
6.4
Medium
MetricsAV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions Rife Elementor Extensions & Templates plugin for WordPress versions up to, and including, 1.2.5
Description The issue is related to Stored Cross-Site Scripting via the plugin's Writing Effect Headline shortcode due to insufficient input sanitization and output escaping on user-supplied attributes. This allows authenticated attackers with contributor-level access and above to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Recommendations For versions up to, and including, 1.2.5, update to a version higher than 1.2.5 to resolve the issue. As a temporary workaround, consider restricting access to the Writing Effect Headline shortcode for users with contributor-level access and above until a patch is available.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾