PT-2025-7489

CVE-2025-1065

·

Published

2025-02-18

·

Updated

2025-03-06

Description by

CVSS 3.1
6.4
Medium
MetricsAV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions The Visualizer: Tables and Charts Manager for WordPress versions up to, and including, 3.11.8
Description The issue is related to Stored Cross-Site Scripting via the plugin's Import Data From File feature due to insufficient input sanitization and output escaping on user-supplied attributes. This allows authenticated attackers with contributor-level access and above to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Recommendations For versions up to, and including, 3.11.8, update to a version newer than 3.11.8 to resolve the issue. As a temporary workaround, consider restricting access to the Import Data From File feature to minimize the risk of exploitation. Additionally, restrict contributor-level access and above to trusted users only.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾