PT-2025-7555
CVE-2025-25299
·
Published
2025-02-20
·
Updated
2025-03-03
Description by
CVSS 4.0
6.9
MediumMetricsAV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
Name of the Vulnerable Software and Affected Versions
CKEditor 5 versions prior to 44.2.1
Description
A Cross-Site Scripting (XSS) vulnerability was discovered in the CKEditor 5 real-time collaboration package, affecting user markers that represent users' positions within the document. This can lead to unauthorized JavaScript code execution with a very specific editor and token endpoint configuration. The vulnerability affects only installations with Real-time collaborative editing enabled.
Recommendations
For versions prior to 44.2.1, update to version 44.2.1 or later to resolve the issue. As a temporary workaround, consider disabling the Real-time collaborative editing feature until the update is applied. Restrict access to the vulnerable user markers to minimize the risk of exploitation. Avoid using specific endpoint configurations that may trigger the vulnerability until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾