PT-2025-7702
CVE-2024-12308
·
Published
2025-02-03
·
Updated
2025-02-24
Description by
CVSS 3.1
5.4
MediumMetricsAV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
Logo Slider WordPress plugin versions prior to 4.6.0
Description
The issue concerns the Logo Slider WordPress plugin, which does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embedded. This could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Recommendations
For versions prior to 4.6.0, update to version 4.6.0 or later to resolve the issue. As a temporary workaround, consider restricting the use of the vulnerable shortcode attributes until a patch is available. Avoid using unvalidated and unescaped shortcode attributes in pages/posts where the shortcode is embedded to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾