PT-2025-7709

CVE-2025-25279

·

Published

2025-02-24

·

Updated

2025-03-13

Description by

CVSS 3.1
9.9
Critical
MetricsAV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Mattermost versions 9.11.x through 9.11.7 Mattermost versions 10.2.x through 10.2.2 Mattermost versions 10.3.x through 10.3.2 Mattermost versions 10.4.x through 10.4.1
Description The issue arises from the improper validation of board blocks when importing boards, allowing an attacker to read any arbitrary file on the system. This can be achieved by importing and exporting a specially crafted import archive in Boards.
Recommendations For versions 9.11.x through 9.11.7, update to a version later than 9.11.7 to resolve the issue. For versions 10.2.x through 10.2.2, update to a version later than 10.2.2 to resolve the issue. For versions 10.3.x through 10.3.2, update to a version later than 10.3.2 to resolve the issue. For versions 10.4.x through 10.4.1, update to a version later than 10.4.1 to resolve the issue.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-5FWX-P6XH-VJRH
GO-2025-3480
OPENSUSE-SU-2025:14889-1
Found an issue in the description? Have something to add? Feel free to write us 👾