PT-2025-7771

CVE-2025-26803

·

Published

2025-02-24

·

Updated

2025-03-02

Description by

CVSS 3.1
7.5
High
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions Phusion Passenger versions 6.0.21 through 6.0.25
Description The issue allows for a denial of service during parsing of a request with an invalid HTTP method, specifically affecting the http parser.
Recommendations For versions 6.0.21 through 6.0.25, update to version 6.0.26 or later to resolve the issue.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-2CJ2-QQXJ-5M3R
BIT-PASSENGER-2025-26803
BIT-PASSENGER-APACHE-MODULE-2025-26803
BIT-PASSENGER-NGINX-MODULE-2025-26803
Found an issue in the description? Have something to add? Feel free to write us 👾