PT-2025-7778
CVE-2025-27112
·
Published
2025-02-24
·
Updated
2025-03-13
Description by
CVSS 4.0
6.9
MediumMetricsAV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N
Name of the Vulnerable Software and Affected Versions
Navidrome versions 0.52.0 through 0.54.4
Description
The issue is related to a flaw in the authentication check process in certain Subsonic API endpoints. This flaw allows an attacker to bypass authentication by specifying any arbitrary non-existent username along with a salted hash of an empty password, granting access to read-only data without valid credentials. The attacker can view various information, such as user playlists, but cannot modify data due to insufficient permissions.
Recommendations
For Navidrome versions 0.52.0 through 0.54.4, update to version 0.54.5 to resolve the issue.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾