PT-2025-8707

CVE-2025-1716

·

Published

2025-02-26

·

Updated

2025-09-30

Description by

CVSS 3.1
9.8
Critical
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions picklescan versions prior to 0.0.21
Description The issue allows an attacker to craft a malicious model that uses Pickle to pull in a malicious PyPI package via pip.main(). This is possible because 'pip' is not treated as an unsafe global, causing the model to pass security checks and appear safe when scanned, even though it could be problematic.
Recommendations For picklescan versions prior to 0.0.21, update to version 0.0.21 or later to resolve the issue. As a temporary workaround, consider restricting the use of the pip.main() function to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-655Q-FX9R-782V
GHSA-769V-P64C-89PR
GHSA-VR75-HJH9-7FR6
PYSEC-2025-18
PYSEC-2025-19
Found an issue in the description? Have something to add? Feel free to write us 👾