PT-2025-9151

CVE-2024-9217

·

Published

2025-02-28

·

Updated

2025-03-02

Description by

CVSS 3.1
6.1
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions Currency Switcher for WooCommerce plugin for WordPress versions up to, and including, 2.16.2
Description The issue is related to Reflected Cross-Site Scripting, which occurs due to the use of add query arg without proper escaping on the URL. This allows unauthenticated attackers to inject arbitrary web scripts into pages that execute when a user performs a specific action, such as clicking on a link.
Recommendations For versions up to, and including, 2.16.2, update to a version higher than 2.16.2 to resolve the issue.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾