PT-2025-9171
CVE-2024-13546
·
Published
2025-02-28
·
Updated
2025-03-02
Description by
CVSS 3.1
4.3
MediumMetricsAV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Name of the Vulnerable Software and Affected Versions
GenerateBlocks plugin for WordPress versions prior to 1.9.2
Description
The issue allows authenticated attackers with Contributor-level access and above to extract sensitive data, including the content of private, draft, and scheduled posts and pages, via the
get image description function.Recommendations
For versions prior to 1.9.2, update to version 1.9.2 or later to resolve the issue. As a temporary workaround, consider restricting access to the
get image description function until a patch is available. Found an issue in the description? Have something to add? Feel free to write us 👾