PT-2025-9589
CVE-2025-0587
·
Published
2025-03-04
·
Updated
2025-03-04
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
OpenHarmony versions prior to 5.0.2
Description
The issue allows a local attacker to execute arbitrary code in pre-installed apps through an integer overflow. This can be exploited only in restricted scenarios.
Recommendations
For versions prior to 5.0.2, update to version 5.0.2 or later to resolve the issue.
Found an issue in the description? Have something to add? Feel free to write us 👾