PT-2025-9858

CVE-2025-27508

·

Published

2025-03-05

·

Updated

2025-03-06

Description by

CVSS 3.1
7.5
High
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Name of the Vulnerable Software and Affected Versions Emissary versions prior to 8.24.0
Description Emissary is a P2P based data-driven workflow engine. The ChecksumCalculator class within allows for hashing and checksum generation, but it includes or defaults to algorithms that are no longer recommended for secure cryptographic use cases, such as SHA-1, CRC32, and SSDEEP. These algorithms can expose users to security risks if used in scenarios where strong cryptographic guarantees are required.
Recommendations For versions prior to 8.24.0, update to version 8.24.0 or later to fix the issue. As a temporary workaround, consider restricting the use of the ChecksumCalculator class to non-security-critical tasks and clearly documenting its limitations to prevent misuse in security-sensitive contexts. Additionally, developers should be aware of the potential security concerns associated with the use of SHA-1, CRC32, and SSDEEP algorithms and take necessary precautions to prevent their use in security-critical implementations.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-HW43-FCMM-3M5G
Found an issue in the description? Have something to add? Feel free to write us 👾