PT-2026-123119

CVE-2026-115635

·

Published

2026-10-25

·

Updated

2026-10-25

Description by

CVSS 4.0
6.0
Medium
MetricsAV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Name of the Vulnerable Software and Affected Versions ash postgres versions 2.6.22 through 2.15.1
Description An incorrect authorization issue exists where a user can read another tenant's record during a skipped upsert. This occurs when Ash.bulk create/4 or a single create operation is executed as an upsert with return skipped upsert?: true and the upsert is skipped, such as when the upsert condition is not met. In these cases, AshPostgres.DataLayer retrieves the existing row using the upsert identity within the do bulk create/3 and upsert/4 functions. Because this lookup fails to apply the resource's attribute multitenancy—a method of isolating data for different tenants using a specific attribute—it may return a row belonging to another tenant that shares the same identity values, exposing sensitive fields to the caller.
Recommendations Update ash postgres to version 2.15.2 or later.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-36HG-WWP2-FG8W
Found an issue in the description? Have something to add? Feel free to write us 👾