PT-2026-127753

Published

2026-10-27

·

Updated

2026-10-27

Description by

CVSS 3.1
8.1
High
MetricsAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

Impact

A Cross-Site Scripting (XSS) vulnerability has been discovered in the CKEditor 5 engine. This vulnerability is caused by a prototype pollution issue in the es-toolkit library used in the CKEditor 5 codebase. This vulnerability could lead to unauthorized JavaScript code execution when the editor processes incoming style attribute values.
The underlying issue has been patched by the library maintainers, and the fix has been incorporated into CKEditor 5.

Patches

The problem has been recognized and patched. The fix will be available in version 48.5.1 (and above) and 47.7.4 (LTS).

For more information

Email us at security@cksource.com if you have any questions or comments about this advisory.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
GHSA-RH54-VFFM-5FVP
Found an issue in the description? Have something to add? Feel free to write us 👾