PT-2026-127756

Published

2026-10-27

·

Updated

2026-10-27

Description by

CVSS 3.1
3.1
Low
MetricsAV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N

Impact

A Cross-Site Scripting (XSS) vulnerability has been discovered in the CKEditor 5 engine. This vulnerability could be triggered by inserting specially crafted markup under a specific General HTML Support configuration that allows inserting objects, leading to unauthorized JavaScript code execution in a browser context isolated from the origin of the application embedding the editor.
This vulnerability affects only installations where General HTML Support is enabled and configured to allow the affected HTML content.

Patches

The problem has been recognized and patched. The fix will be available in version 48.5.1 (and above) and 47.7.4 (LTS).

For more information

Email us at security@cksource.com if you have any questions or comments about this advisory.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
GHSA-V6MG-96C6-GMPQ
Found an issue in the description? Have something to add? Feel free to write us 👾