PT-2026-130582
CVE-2026-118553
·
Published
2026-10-28
·
Updated
2026-10-30
Description by
Score
N/A
Not availableNo severity ratings or metrics are available. When they are, we'll update the corresponding info on the page.
Name of the Vulnerable Software and Affected Versions
Drupal AI versions 0.0.0 through 1.4.11
Drupal AI versions 1.5.0 through 1.5.2
Description
Stored Cross-site Scripting (XSS) occurs due to improper neutralization of input during web page generation. The AI Automator submodule, which enables automatic field population based on other fields, fails to sufficiently verify access to text formats. This allows users to author field data using text formats they are not authorized to use.
Recommendations
Update Drupal AI versions 0.0.0 through 1.4.11 to a fixed version.
Update Drupal AI versions 1.5.0 through 1.5.2 to a fixed version.
Restrict access to the AI Automator submodule to minimize the risk of unauthorized text format usage.
Found an issue in the description? Have something to add? Feel free to write us 👾