PT-2026-138450

CVE-2026-69128

·

Published

2026-11-06

·

Updated

2026-11-06

Description by

CVSS 4.0
4.6
Medium
MetricsAV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Name of the Vulnerable Software and Affected Versions Chartbrew versions prior to 5.2.3
Description The AI query tool's PostgreSQL SQL-validation blocklist fails to include sibling PostgreSQL filesystem functions and does not match double-quoted identifier forms of denied functions. This allows a team Owner or Admin with an AI-enabled PostgreSQL connection to bypass the denylist regular expressions. If the database role has permissions to call server-side file functions, such as a PostgreSQL superuser or the pg read server files role, they can resolve absolute paths to files readable by the PostgreSQL OS user. Non-superusers are limited to the PGDATA-relative scope. This issue requires AI features to be enabled and elevated user privileges.
Recommendations Update to version 5.2.3.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-JW2R-HRXG-CFGC
Found an issue in the description? Have something to add? Feel free to write us 👾