PT-2026-22421

CVE-2026-28422

·

Published

2026-02-27

·

Updated

2026-07-30

Description by

CVSS 3.1
7.8
High
MetricsAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Vim versions prior to 9.2.0078
Description Vim is an open source, command line text editor. A stack-based buffer overflow occurs in the build stl str hl() function when rendering a statusline with a multi-byte fill character on a very wide terminal. This can potentially impact the integrity of protected information.
Recommendations Versions prior to 9.2.0078 should be updated to version 9.2.0078 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-GMQX-PRF2-8MWF
AZL-78512
CLSA-2026-1785426678
CLSA-2026-1785427487
ECHO-F134-6EF2-2906
MGASA-2026-0049
OESA-2026-1565
SUSE-SU-2026:0910-1
SUSE-SU-2026:1051-1
SUSE-SU-2026:1095-1
USN-8101-1
Found an issue in the description? Have something to add? Feel free to write us 👾