PT-2026-25070
CVE-2026-32259
·
Published
2026-01-01
·
Updated
2026-10-09
Description by
CVSS 3.1
8.1
HighMetricsAV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
ImageMagick versions prior to 7.1.2-16
ImageMagick versions prior to 6.9.13-41
Description
ImageMagick is free and open-source software used for editing and manipulating digital images. Before versions 7.1.2-16 and 6.9.13-41, a failure in memory allocation within the sixel encoder could lead to writing beyond the bounds of a stack-allocated buffer. The sixel encoder is a component responsible for handling a specific image format.
Recommendations
ImageMagick versions prior to 7.1.2-16 should be updated to version 7.1.2-16 or later.
ImageMagick versions prior to 6.9.13-41 should be updated to version 6.9.13-41 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾