PT-2026-29156
CVE-2026-33762
·
Published
2026-03-29
·
Updated
2026-10-15
Description by
CVSS 3.1
2.8
LowMetricsAV:L/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L
Name of the Vulnerable Software and Affected Versions
go-git versions prior to 5.17.1
Description
The
go-git library’s index decoder for Git index format version 4 does not properly validate the path name prefix length before applying it to the previously decoded path name. A specially crafted index file can cause an out-of-bounds slice operation, leading to a runtime panic during index parsing. This issue only affects Git index format version 4. An attacker with the ability to modify or inject a Git index file within a local repository can cause applications using go-git to terminate, resulting in a denial-of-service (DoS) condition.Recommendations
Upgrade to version 5.17.1, or the latest version 6.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾