PT-2026-30278

CVE-2026-35029

·

Published

2026-04-03

·

Updated

2026-10-24

Description by

CVSS 3.1
8.8
High
MetricsAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions LiteLLM versions prior to 1.83.0
Description An authorization flaw exists in the update config() function, which handles the '/config/update' endpoint. The endpoint fails to enforce admin role authorization, allowing any authenticated user or holder of a valid API key to modify proxy configurations and environment variables. This can lead to remote code execution by registering custom pass-through endpoint handlers that point to attacker-controlled Python code. Additionally, attackers can read arbitrary server files by manipulating the UI LOGO PATH variable and fetching them via the '/get image' endpoint, or take over privileged accounts by overwriting the UI USERNAME and UI PASSWORD environment variables. Real-world probing of the '/config/update' endpoint was observed shortly after the issue became public.
Recommendations Update to version 1.83.0. Restrict API key distribution to minimize the risk of unauthorized access.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-53MR-6C8Q-9789
ECHO-F909-9693-1F3F
PYSEC-2026-2597
Found an issue in the description? Have something to add? Feel free to write us 👾