PT-2026-3072

CVE-2026-22265

·

Published

2026-01-15

·

Updated

2026-02-18

Description by

CVSS 3.1
7.5
High
MetricsAV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Roxy-WI versions prior to 8.2.8.2
Description Roxy-WI, a web interface for managing Haproxy, Nginx, Apache and Keepalived servers, contains a command injection issue in the log viewing functionality. Authenticated users can execute arbitrary system commands due to unsanitized input used with the grep parameter in app/modules/roxywi/logs.py line 87. The parameter is used both sanitized and raw, creating the opportunity for exploitation.
Recommendations Upgrade to Roxy-WI version 8.2.8.2 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-MMMF-VH7M-RM47
Found an issue in the description? Have something to add? Feel free to write us 👾