PT-2026-32030

CVE-2026-40175

·

Published

2026-04-09

·

Updated

2026-11-05

Description by

CVSS 2.0
10
High
MetricsAV:N/AC:L/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions axios versions prior to 1.15.0 axios versions prior to 0.3.1
Description The axios library is vulnerable to a gadget attack chain where prototype pollution in any third-party dependency can be escalated. This occurs because the library does not sanitize HTTP header values for carriage return and line feed (CRLF) characters, allowing an attacker to inject separate HTTP requests. This can lead to request smuggling, server-side request forgery (SSRF), and the bypass of AWS IMDSv2 to exfiltrate cloud metadata and IAM credentials, potentially resulting in remote code execution (RCE) or full cloud compromise. The issue is particularly risky when using custom axios adapters or non-standard configurations that bypass the standard Node.js HTTP stack, as the runtime typically blocks CRLF injection.
Recommendations Update axios to version 1.15.0 or newer. Update axios to version 0.3.1 or newer. As a temporary workaround, restrict the use of custom axios adapters or manual request constructions that bypass the standard HTTP stack.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
GHSA-FVCV-3M26-PCQX
CLEANSTART-2026-BE61221
CLEANSTART-2026-LC05413
CLEANSTART-2026-QI58975
CLEANSTART-2026-XR95601
ECHO-B49D-4738-7E8F
RHSA-2026:24762
USN-8638-1
Found an issue in the description? Have something to add? Feel free to write us 👾