PT-2026-39412
CVE-2026-44580
·
Published
2026-05-06
·
Updated
2026-09-28
Description by
CVSS 2.0
6.4
MediumMetricsAV:N/AC:L/Au:N/C:P/I:P/A:N
Name of the Vulnerable Software and Affected Versions
Next.js versions 13.0.0 through 15.5.15
Next.js versions 16.0.0 through 16.2.4
Description
Applications using
beforeInteractive scripts combined with untrusted content are susceptible to cross-site scripting (XSS), a flaw where malicious scripts are injected into trusted websites. Serialized script content was not safely escaped before being embedded into the document, allowing attacker-controlled input to exit the intended script context and execute arbitrary JavaScript in the visitor's browser.Recommendations
Update to version 15.5.16.
Update to version 16.2.5.
Avoid passing untrusted data into
beforeInteractive scripts.
Sanitize or escape content before embedding it if using untrusted data in beforeInteractive scripts is unavoidable.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾