PT-2026-39754
CVE-2026-45109
·
Published
2026-05-11
·
Updated
2026-10-09
Description by
CVSS 2.0
7.8
HighMetricsAV:N/AC:L/Au:N/C:C/I:N/A:N
Name of the Vulnerable Software and Affected Versions
Next.js versions 15.2.0 through 15.5.17
Next.js versions 16.0.0 through 16.2.5
Description
A flaw exists where a previous security fix was not correctly applied to
middleware.ts when used in conjunction with Turbopack, a high-performance incremental bundler for JavaScript and TypeScript.Recommendations
Update to version 15.5.18.
Update to version 16.2.6.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾