PT-2026-40931
CVE-2026-24712
·
Published
2026-05-14
·
Updated
2026-05-19
Description by
CVSS 3.1
7.3
HighMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Name of the Vulnerable Software and Affected Versions
CFEngine Enterprise and Community versions prior to 3.21.8
CFEngine Enterprise and Community versions prior to 3.24.3
CFEngine Enterprise and Community versions prior to 3.27.0
Description
CFEngine Enterprise and Community are affected by command injection and cross-site scripting (XSS), a flaw where an attacker can inject malicious scripts into web pages viewed by other users.
Recommendations
Update to version 3.21.8 or later.
Update to version 3.24.3 or later.
Update to version 3.27.0 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾