PT-2026-42539

CVE-2026-47102

·

Published

2026-02-19

·

Updated

2026-10-08

Description by

CVSS 2.0
9.0
High
MetricsAV:N/AC:L/Au:S/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions LiteLLM versions prior to 1.83.10
Description An issue exists where the '/user/update' endpoint does not restrict which fields a user can modify when updating their own account. This allows a user to change their user role to proxy admin, granting full administrative access to all users, teams, keys, models, and prompt history. Users with the org admin role can exploit this directly as they have legitimate access to the endpoint.
Recommendations Update to version 1.83.10 or later. As a temporary workaround, restrict access to the '/user/update' endpoint to prevent unauthorized modification of the user role variable.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
GHSA-WPFP-GWWC-VWQ6
ECHO-91AC-5D81-2D88
PYSEC-2026-2600
Found an issue in the description? Have something to add? Feel free to write us 👾