PT-2026-54637
CVE-2026-13769
·
Published
2026-07-01
·
Updated
2026-10-25
Description by
CVSS 4.0
6.8
MediumMetricsAV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
Name of the Vulnerable Software and Affected Versions
AWS CLI versions prior to 1.44.78 (v1)
AWS CLI versions prior to 2.34.29 (v2)
Description
On Unix-like systems where the umask is not configured to restrict file permissions, overly permissive file permissions may allow local users on the same host to read credentials. This occurs when certain CLI subcommands are used, specifically 'aws codeartifact login', 'aws iam create-virtual-mfa-device', and 'aws deploy register'.
Recommendations
Upgrade to AWS CLI version 1.44.78 (v1) or later.
Upgrade to AWS CLI version 2.34.29 (v2) or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾