PT-2026-60305

CVE-2026-56679

·

Published

2026-07-15

·

Updated

2026-09-23

Description by

CVSS 4.0
8.7
High
MetricsAV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N
Name of the Vulnerable Software and Affected Versions 9Router versions prior to 0.5.4
Description An authenticated user can modify security-critical settings because the PATCH '/api/settings' endpoint writes the entire request body to persistent settings without using a field whitelist. By manipulating fields such as requireLogin, an attacker can disable authentication for the entire application, granting unauthenticated access to protected routes including '/api/keys' and '/api/providers'.
Recommendations Update to version 0.5.4.
Exploitability
Exploit
Fix
Vendors
Affected products
Related identifiers
GHSA-VMJQ-HVGQ-2WV4
Found an issue in the description? Have something to add? Feel free to write us 👾