PT-2026-60950
CVE-2024-58370
·
Published
2024-01-18
·
Updated
2026-07-21
Description by
CVSS 4.0
7.1
HighMetricsAV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
Name of the Vulnerable Software and Affected Versions
SurrealDB versions prior to 1.1.0
Description
The software fails to enforce recursion depth limits when parsing nested SurrealQL statements, specifically involving IF, RELATE, and attribute access idioms. Authorized attackers can submit queries with excessive nesting depth to trigger a stack overflow, which leads to a server crash.
Recommendations
Update to version 1.1.0 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾