PT-2026-61688

CVE-2026-63108

·

Published

2026-07-20

·

Updated

2026-07-21

Description by

CVSS 3.1
8.8
High
MetricsAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Roo Code versions prior to 3.54.1
Description A command injection issue exists in the auto-approve execute feature. Attackers can bypass allowlist and denylist enforcement by nesting command substitutions within parameter expansion defaults. The command parser in parse-command.ts replaces parameter expansions with opaque placeholders before extracting command substitutions. This process causes the containsDangerousSubstitution() guard to overlook nested payloads, which are then auto-approved based on the outer allowlisted command prefix and executed by the shell via execa, allowing for arbitrary command execution.
Recommendations Update Roo Code to a version newer than 3.54.0. As a temporary mitigation, disable the auto-approve execute feature until the update is applied.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾