PT-2026-61720
CVE-2026-56624
·
Published
2026-07-20
·
Updated
2026-10-08
Description by
CVSS 3.1
7.3
HighMetricsAV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
Name of the Vulnerable Software and Affected Versions
Apache MINA SSHD versions prior to 2.19.0
Apache MINA SSHD versions prior to 3.0.0-M5
Description
Improper certificate validation occurs during server-side OpenSSH user authentication. The server fails to check or validate the
force-command or verify-required options embedded in certificates. This allows a user to authenticate with a certificate containing a force-command option and potentially execute commands other than the one specified, depending on the server implementation.Recommendations
Upgrade to version 2.19.0.
Upgrade to version 3.0.0-M5.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾