PT-2026-63345

CVE-2026-65015

·

Published

2026-07-22

·

Updated

2026-10-06

Description by

CVSS 3.1
8.8
High
MetricsAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions n8n versions prior to 2.30.1
Description A privilege escalation issue exists in the AI Agents feature where the node-execution tool lacks proper authorization checks. A user with the Project Viewer role can escalate privileges by interacting with an agent that has node tools enabled. The tool was authorized only by the agent:execute scope and executed nodes using project credentials without verifying if the requesting user had permission to execute those nodes or access the credentials. This allows a Project Viewer to execute arbitrary tool nodes and access unauthorized credential secrets. If command- or file-capable tool nodes, such as Execute Command or SSH, are enabled, this can lead to arbitrary command execution on the host server.
Recommendations Update to version 2.29.8 or 2.30.1. Disable the AI Agents module by removing agents from the N8N ENABLED MODULES environment variable. Restrict project membership to fully trusted users and avoid granting Project Viewer access to untrusted users on projects with agents that have node tools enabled. Disable command-execution nodes, such as Execute Command or SSH, to limit potential impact.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-W46P-W7W2-FR9G
GHSA-X5VX-C2C8-M3W9
Found an issue in the description? Have something to add? Feel free to write us 👾