PT-2026-63974

CVE-2026-65608

·

Published

2026-07-23

·

Updated

2026-09-17

Description by

CVSS 3.1
8.8
High
MetricsAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Grav versions 1.7.0 through 2.0.8
Description Authenticated users with create or update permissions on Flex-based directories, such as Flex Users, Flex Pages, Flex Objects, or custom Flex types, can execute arbitrary shell commands on the server. The issue occurs because the FlexDirectory::dynamicDataField() function resolves blueprint data-*@: directives by using call user func array() on input influenced by the user. While the system checks if the target is callable via is callable(), it fails to restrict dangerous functions like exec, system, passthru, or shell exec. This behavior bypasses previous validations implemented in Blueprint::dynamicData().
Recommendations Update Grav to version 2.0.9 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-C4WF-2XXC-68QM
GHSA-PP9R-PPC4-25W4
Found an issue in the description? Have something to add? Feel free to write us 👾