PT-2026-71445

CVE-2026-73617

·

Published

2026-07-24

·

Updated

2026-10-23

Description by

CVSS 3.1
7.1
High
MetricsAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
Name of the Vulnerable Software and Affected Versions Budibase versions prior to 3.40.0
Description A NoSQL injection issue exists in the MongoDB datasource integration. The problem occurs because user-supplied parameters are processed using handlebars with noEscaping: true and are parsed without operator filtering. This allows attackers to inject MongoDB operators through query parameters to bypass per-user access controls, read arbitrary documents, execute JavaScript via $where operators, or modify collections through update and delete operations.
Recommendations Update Budibase to version 3.40.0 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-PMPG-2MXQ-6XWR
Found an issue in the description? Have something to add? Feel free to write us 👾