PT-2026-71468
CVE-2026-14670
·
Published
2026-08-12
·
Updated
2026-10-02
Description by
CVSS 2.0
9.0
HighMetricsAV:N/AC:L/Au:S/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
PostgreSQL versions prior to 18.5
PostgreSQL versions prior to 17.11
PostgreSQL versions prior to 16.15
PostgreSQL versions prior to 15.19
PostgreSQL versions prior to 14.24
Description
A heap buffer overflow occurs in the plperl language handler when returning a tied hash. This allows a function owner to execute arbitrary code with the privileges of the operating system user running the database by using a specially crafted function body.
Recommendations
Update to version 18.5 or later.
Update to version 17.11 or later.
Update to version 16.15 or later.
Update to version 15.19 or later.
Update to version 14.24 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾