PT-2026-71474
CVE-2026-14678
·
Published
2026-08-12
·
Updated
2026-10-25
Description by
CVSS 3.1
4.3
MediumMetricsAV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Name of the Vulnerable Software and Affected Versions
PostgreSQL versions prior to 18.5
PostgreSQL versions prior to 17.11
PostgreSQL versions prior to 16.15
PostgreSQL versions prior to 15.19
PostgreSQL versions prior to 14.24
Description
A buffer over-read occurs in the
picksplit() function of the pg trgm index, where the system reads past the end of a heap buffer. This issue may allow a table maintainer to infer limited memory values by analyzing the lossy signal of index split choices.Recommendations
Update to version 18.5 or later.
Update to version 17.11 or later.
Update to version 16.15 or later.
Update to version 15.19 or later.
Update to version 14.24 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾