PT-2026-71478

CVE-2026-15741

·

Published

2026-08-12

·

Updated

2026-10-02

Description by

CVSS 2.0
9.0
High
MetricsAV:N/AC:L/Au:S/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions PostgreSQL versions prior to 18.5 PostgreSQL versions prior to 17.11 PostgreSQL versions prior to 16.15 PostgreSQL versions prior to 15.19 PostgreSQL versions prior to 14.24
Description An SQL injection exists in the EXTRACT() deparse functionality. This allows an object owner to execute arbitrary SQL commands with superuser privileges by using a hostile object definition. The issue impacts expression deparse consumers, including the pg dump utility, psql commands such as sf, and similar implementations in non-core tools.
Recommendations Update to version 18.5 or later. Update to version 17.11 or later. Update to version 16.15 or later. Update to version 15.19 or later. Update to version 14.24 or later.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
ALSA-2026:67280
ALSA-2026:67491
ALSA-2026:67848
ALSA-2026:69876
ALSA-2026:69914
ALSA-2026:69923
ALSA-2026:70186
AZL-95684
BIT-POSTGRESQL-2026-15741
ECHO-3067-E4D3-8356
OESA-2026-3420
OESA-2026-3421
OESA-2026-3422
OESA-2026-3423
OESA-2026-3424
OPENSUSE-SU-2026:11552-1
OPENSUSE-SU-2026:11553-1
OPENSUSE-SU-2026:11554-1
OPENSUSE-SU-2026:11555-1
OPENSUSE-SU-2026:11565-1
OPENSUSE-SU-2026:21699-1
OPENSUSE-SU-2026:21700-1
OPENSUSE-SU-2026:21701-1
OPENSUSE-SU-2026:21702-1
OPENSUSE-SU-2026:21703-1
SUSE-SU-2026:23577-1
SUSE-SU-2026:23578-1
SUSE-SU-2026:23579-1
SUSE-SU-2026:23580-1
SUSE-SU-2026:23582-1
SUSE-SU-2026:3793-1
SUSE-SU-2026:3794-1
SUSE-SU-2026:3940-1
SUSE-SU-2026:3941-1
SUSE-SU-2026:3942-1
SUSE-SU-2026:3943-1
SUSE-SU-2026:3944-1
SUSE-SU-2026:3963-1
SUSE-SU-2026:4013-1
SUSE-SU-2026:4014-1
SUSE-SU-2026:4015-1
SUSE-SU-2026:4016-1
SUSE-SU-2026:4017-1
SUSE-SU-2026:4018-1
USN-8653-1
Found an issue in the description? Have something to add? Feel free to write us 👾