PT-2026-7843
CVE-2026-2003
·
Published
2026-01-01
·
Updated
2026-09-18
Description by
CVSS 3.1
4.3
MediumMetricsAV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Name of the Vulnerable Software and Affected Versions
PostgreSQL versions prior to 18.2
PostgreSQL versions prior to 17.8
PostgreSQL versions prior to 16.12
PostgreSQL versions prior to 15.16
PostgreSQL versions prior to 14.21
Description
A flaw exists in PostgreSQL due to improper validation of the 'oidvector' type. This can allow a database user to reveal a limited amount of server memory. While the possibility of exposing confidential information through this method seems unlikely, it has not been entirely dismissed.
Recommendations
Update to PostgreSQL version 18.2 or later.
Update to PostgreSQL version 17.8 or later.
Update to PostgreSQL version 16.12 or later.
Update to PostgreSQL version 15.16 or later.
Update to PostgreSQL version 14.21 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾