PT-2026-7844
CVE-2026-2004
·
Published
2026-01-01
·
Updated
2026-09-18
Description by
CVSS 2.0
9.0
HighMetricsAV:N/AC:L/Au:S/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
PostgreSQL versions prior to 18.2
PostgreSQL versions prior to 17.8
PostgreSQL versions prior to 16.12
PostgreSQL versions prior to 15.16
PostgreSQL versions prior to 14.21
Description
A lack of input type validation within the selectivity estimator function of the PostgreSQL intarray extension can allow an attacker to execute arbitrary code as the operating system user running the database. The issue resides in the intarray extension.
Recommendations
Update to PostgreSQL version 18.2 or later.
Update to PostgreSQL version 17.8 or later.
Update to PostgreSQL version 16.12 or later.
Update to PostgreSQL version 15.16 or later.
Update to PostgreSQL version 14.21 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾