PT-2026-7845
CVE-2026-2005
·
Published
2026-01-01
·
Updated
2026-10-22
Description by
CVSS 2.0
9.0
HighMetricsAV:N/AC:L/Au:S/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
PostgreSQL versions prior to 18.2
PostgreSQL versions prior to 17.8
PostgreSQL versions prior to 16.12
PostgreSQL versions prior to 15.16
PostgreSQL versions prior to 14.21
Description
A heap buffer overflow in the
pgcrypto component allows a ciphertext provider to execute arbitrary code as the operating system user running the database. This issue may enable a remote attacker or low-privilege users to achieve remote code execution.Recommendations
Update to version 18.2
Update to version 17.8
Update to version 16.12
Update to version 15.16
Update to version 14.21
As a temporary workaround, restrict the use of the
pgcrypto module to minimize the risk of exploitation. Found an issue in the description? Have something to add? Feel free to write us 👾