PT-2026-8282

CVE-2026-26080

·

Published

2026-01-01

·

Updated

2026-09-07

Description by

CVSS 3.1
3.7
Low
MetricsAV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
Name of the Vulnerable Software and Affected Versions HAProxy Community Edition versions 3.2.x through 3.3.2 HAProxy Enterprise (affected versions not specified) ALOHA (affected versions not specified)
Description An issue exists where the software can enter a loop or crash due to the mishandling of varint, which is a method of serializing integers using a variable number of bytes to save space.
Recommendations Update HAProxy Community Edition to version 3.3.3 or later.
Exploitability
Exploit
Fix
Impacts
Vendors
Affected products
Related identifiers
BIT-HAPROXY-2026-26080
OPENSUSE-SU-2026:20290-1
RHSA-2026:40938
SUSE-SU-2026:20557-1
SUSE-SU-2026:20616-1
SUSE-SU-2026:20620-1
Found an issue in the description? Have something to add? Feel free to write us 👾